Skip to content
87

Awesome Microservices

A curated list of Microservice Architecture related principles and technologies.

15k stars1,860 forks377 entriesLast push Aug 20, 2026 (1 month ago)License CC0-1.0

This page lists names, links and short descriptions. The original list on GitHub is the source and belongs to its authors.

Platforms

1Backend

AI-native microservices platform.

In 3 lists

Jolie

Open source microservice-oriented programming language.

OpenWhisk

Serverless, open source cloud platform that executes functions in response to events at any scale.

In 2 lists

Pulumi

SDK for cloud native infrastructure as code. Use your favorite language to preview and manage updates to your apps and infrastructure, and continuously deploy to any cloud (no YAML required).

Triton

Open-source cloud management platform that delivers next generation, container-based, service-oriented infrastructure across one or more data centers.

Frameworks / Runtimes

Akka

Toolkit and runtime for building highly concurrent, distributed, and resilient message-driven applications on the JVM.

In 3 lists

Axon (c)

An end-to-end development and infrastructure platform for easy development and running of any DDD, CQRS and Event Sourcing applications on JVM.

Ballerina

Cloud native programming language.

In 2 lists

Bun

Fast all-in-one JavaScript runtime.

In 3 lists

Dapr

Open source runtime for writing highly performant microservices using any programming language.

Deno

JavaScript, TypeScript, and WebAssembly runtime with secure defaults and a great developer experience.

Eclipse Microprofile

An open forum to optimize Enterprise Java for a microservices architecture by innovating across multiple implementations and collaborating on common areas of interest with a goal of standardization.

Erlang/OTP

Programming language used to build massively scalable soft real-time systems with requirements on high availability.

Finagle

Extensible RPC system for the JVM, used to construct high-concurrency servers.

Gleam

A friendly language for building type-safe, scalable systems.

In 3 lists

GraalVM

High-performance runtime that provides significant improvements in application performance and efficiency which is ideal for microservices.

Helidon

Collection of Java libraries for writing microservices that run on a fast web core powered by Netty.

Ice

Comprehensive RPC framework with support for C++, C#, Java, JavaScript, Python, and more.

In 3 lists

Light-4j

A high throughput, low latency, small memory footprint and more productive microservices platform.

In 2 lists

Micronaut

A modern, JVM-based, full-stack framework for building modular, easily testable microservice applications.

In 2 lists

Moleculer

Fast & powerful microservices framework for Node.js, Java, Go and Ruby.

Open Liberty

A lightweight open framework for building fast and efficient cloud-native Java microservices.

Pears

Peer-to-peer runtime, development and deployment.

SmallRye

APIs and implementations tailored for cloud development, including Eclipse MicroProfile.

Spin

An open source framework for building and running fast, secure, and composable cloud microservices with WebAssembly.

In 2 lists

ScaleCube

Toolkit for building reactive microservices for the JVM: low-latency, high-throughput, scalable and resilient.

Vert.X

Toolkit for building reactive applications on the JVM.

Vert.X Toolbox

A set of Vert.x components to build reactive microservice applications.

Wangle

A framework providing a set of common client/server abstractions for building services in a consistent, modular, and composable way.

In 2 lists

Service Toolkits >Polyglot

GRPC

A high performance, open source, general RPC framework that puts mobile and HTTP/2 first. Libraries in C, C++, Java, Go, Node.js, Python, Ruby, Objective-C, PHP and C#.

In 2 lists

Service Toolkits >C

Lwan

High-performance and scalable web server.

uSockets

Miniscule cross-platform eventing, networking & crypto for async applications.

Service Toolkits >C++

Cap’n Proto RPC

The Cap’n Proto C++ RPC implementation.

C++ Micro Services

An OSGi-like C++ dynamic module system and service registry.

Enduro/X

XATMI based service framework for GNU/Linux.

Pistache

A high-performance REST toolkit written in C++.

Poco

C++ class libraries for building network-based applications and servers.

Sogou Workflow

Enterprise-grade programming engine aimed to satisfy most of the backend development requirements.

In 6 listsDetails

uWebSockets

Simple, secure & standards compliant web server for the most demanding of applications.

In 7 listsDetails

Service Toolkits >D

Vibe.d

Asynchronous I/O that doesn’t get in your way, written in D.

Service Toolkits >Erlang VM

Phoenix

Framework for building HTML5 apps, API backends and distributed systems.

Plug

A specification and conveniences for composable modules between web applications.

In 2 lists

Cowboy

Small, fast, modular HTTP server written in Erlang.

In 2 lists

Mochiweb

Erlang library for building lightweight HTTP servers.

In 3 lists

Service Toolkits >Go

Chi

Lightweight, idiomatic and composable router for building Go HTTP services.

In 4 listsDetails

Echo

Fast and unfancy HTTP server framework for Go. Up to 10x faster than the rest.

In 2 lists

Fiber

Express inspired web framework built on top of Fasthttp, the fastest HTTP engine for Go. Designed to ease things up for fast development with zero memory allocation and performance in mind.

In 8 listsDetails

Gin

Gin is a HTTP web framework written in Go (Golang). It features a Martini-like API with much better performance, up to 40 times faster.

In 6 listsDetails

Goa

Design-based HTTP microservices in Go.

In 5 listsDetails

GoFr

An opinionated microservice development framework emphasizing scalability and robustness. Designed to simplify the development of microservices.

In 4 listsDetails

Go Chassis

A framework for rapid development of microservices in Go that is easy to integrate with some cloud ecosystems.

In 4 listsDetails

Go-micro

A distributed systems development framework.

In 5 listsDetails

Go-zero

A web and rpc distributed system development framework.

In 4 listsDetails

Gorilla

Web toolkit for the Go programming language.

Iris

Fast, simple and efficient micro web framework for Go.

In 4 listsDetails

Lura

Framework to build ultra performance API Gateways with middlewares.

In 7 listsDetails

RPCX

A distributed RPC service framework based on NET/RPC like Alibaba Dubbo and Weibo Motan.

In 7 listsDetails

Service Toolkits >Haskell

Scotty

Micro web framework inspired by Ruby's Sinatra, using WAI and Warp.

In 2 lists

Servant

Type-level web DSL.

Yesod

The Haskell RESTful web framework.

Service Toolkits >Java VM

Compojure

A concise routing library for Ring/Clojure.

In 2 lists

Duct

A server-side framework for Clojure.

System

Built on top of Stuart Sierra's component library, offers a set of readymade components.

In 2 lists

Tesla

Common basis for some of Otto.de's Clojure microservices.

ActiveJ

Lightweight and fast library for complex high-load distributed applications and Memcached-like solutions.

In 2 lists

Airlift

Framework for building REST services in Java.

Armeria

Open-source asynchronous HTTP/2 RPC/REST client/server library built on top of Java 8, Netty, Thrift and gRPC.

Disruptor

High-performance inter-thread messaging library.

In 4 listsDetails

Dropwizard

Java framework for developing ops-friendly, high-performance, RESTful web services.

In 4 listsDetails

Dubbo

A high-performance, java based RPC framework open-sourced by Alibaba.

In 2 lists

Conjure

Opinionated set of libraries for defining and creating RESTish/RPC servers and clients based on Feign or Retrofit as a client and Dropwizard/Jersey with JAX-RS service definitions as a server.

Jersey

RESTful services in Java. JAX-RS reference implementation.

In 2 lists

Quarkus

A Kubernetes Native Java stack tailored for OpenJDK HotSpot and GraalVM, crafted from the best of breed Java libraries and standards.

Ratpack

Set of Java libraries that facilitate fast, efficient, evolvable and well tested HTTP applications. specific support for the Groovy language is provided.

Spring Boot

Makes it easy to create stand-alone, production-grade Spring based applications.

In 3 lists

Http4k

Lightweight but fully-featured HTTP toolkit written in pure Kotlin that enables the serving and consuming of HTTP services in a functional and consistent way.

Ktor

Framework for building asynchronous servers and clients in connected systems using the Kotlin programming language.

Finatra

Fast, testable, Scala HTTP services built on Twitter-Server and Finagle.

Http4s

A minimal, idiomatic Scala interface for HTTP

Play

The high velocity web framework for Java and Scala.

Service Toolkits >Node.js

Actionhero

Multi-transport Node.js API server with integrated cluster capabilities and delayed tasks.

Express

Fast, unopinionated, minimalist web framework for Node.js

Fastify

Fastify, Fast and low overhead web framework, for Node.js.

FeathersJS

An open source REST and realtime API layer for modern applications.

Hono

Small, simple, and ultrafast web framework for the Edges. It works on any JavaScript runtime.

In 2 lists

Koa

Next generation web framework for Node.js

Loopback

Node.js framework for creating APIs and easily connecting to backend data sources.

In 2 lists

NestJS

A Node.js framework for building efficient and scalable server-side applications with a built-in microservices support.

In 4 listsDetails

Seneca

A microservices toolkit for Node.js

In 4 listsDetails

Serverless

Build and maintain web, mobile and IoT applications running on AWS Lambda and API Gateway (formerly known as JAWS).

In 7 listsDetails

tRPC

End-to-end typesafe APIs.

In 2 lists

Service Toolkits >Perl

Cro

Libraries for creating reactive distributed systems using Perl 6.

Mojolicious

Next generation web framework for Perl.

Service Toolkits >PHP

API Platform

API-first web framework on top of Symfony with JSON-LD, Schema.org and Hydra support.

In 2 lists

Ecotone

Framework based on architectural principles of DDD, CQRS and Event Sourcing that provides building blocks to create scalable and extensible applications.

Hyperf

Hyperf is an extremely performant and flexible PHP CLI framework based on Swoole 4.5+, powered by the state-of-the-art coroutine server and a large number of battle-tested components.

Lumen

Stunningly fast micro-framework.

In 3 lists

Slim

Micro-framework that helps you quickly write simple yet powerful web applications and APIs.

Spiral

Framework designed for long-running applications using RoadRunner. It offers advanced features like integration with the Temporal workflow engine and Centrifugo websocket server. It is particularly effective for microservices architecture, providing robust support for REST APIs and gRPC services.

Swoft

PHP microservices coroutine framework for building high-performance web systems, APIs, middleware, and basic services.

Symfony

Micro-framework based on the Symfony components.

Service Toolkits >Python

Aiohttp

HTTP client/server for asyncio.

In 4 listsDetails

Bottle

Fast, simple and lightweight WSGI micro web-framework for Python.

In 2 lists

Connexion

Swagger/OpenAPI framework for Python on top of Flask with automatic endpoint validation and OAuth2 support.

Falcon

Bare-metal Python web API framework for building very fast app backends and microservices.

In 3 lists

FastAPI

Modern, fast (high-performance), web framework for building APIs with Python 3.6+ based on standard Python type hints.

In 6 listsDetails

Flask

Python framework for microservices based on Werkzeug and Jinja 2.

Nameko

Python framework for building microservices.

Sanic

Sanic is a Flask-like Python 3.5+ web server that's written to go fast.

In 2 lists

Tornado

Web framework and asynchronous networking library.

Twisted

Event-driven network programming engine.

Web.py

Minimalist web framework for Python.

In 2 lists

Service Toolkits >Ruby

Grape

An opinionated framework for creating REST-like APIs

In 2 lists

Hanami

A modern web framework for Ruby.

Praxis

Framework for both designing and implementing APIs.

Scorched

Light-weight web framework for Ruby.

Sinatra

Sinatra is a DSL for quickly creating web applications in Ruby with minimal effort.

In 3 lists

Service Toolkits >Rust

Are we web yet?

star: - A summary of the current state of web programming in Rust.

Actix

Powerful, pragmatic, and extremely fast web framework for Rust.

In 3 lists

Tarpc

RPC framework for Rust with a focus on ease of use.

Tokio

Asynchronous runtime for writing network applications.

Tower

Library of modular and reusable components for building robust networking clients and servers.

Wtx

HTTP/2 client/server framework.

In 8 listsDetails

Frontend / UI

Awesome Micro Frontends

star: - A curated list of resources about Micro Frontends.

In 3 lists

Electrode

Universal React/Node.js application platform.

Micro Frontends

Extending the microservice idea to frontend development.

MiniApp White Paper

MiniApp standardization white paper.

Capabilities >API Gateways / Edge Services

Ambassador (c)

Kubernetes-native API gateway for microservices built on Envoy.

In 2 lists

Apache APISIX

High-performance, real-time API gateway and AI gateway built on NGINX and etcd, with hot-reloaded routing and 100+ plugins.

APIcast

APIcast is an API gateway built on top of NGINX. It is part of the Red Hat 3scale API Management Platform.

Bunker Web

Web app hosting and reverse proxy secure by default.

In 7 listsDetails

Caddy

Extensible HTTP/2 web server with automatic HTTPS.

In 5 listsDetails

Camel

Empowers you to define routing and mediation rules in a variety of domain-specific languages, including a Java-based fluent API, Spring or Blueprint XML configuration files, and a Scala DSL.

In 2 lists

Envoy

Open source edge and service proxy, from the developers at Lyft.

HAProxy

Reliable, high Performance TCP/HTTP load balancer.

In 3 lists

Istio

An open platform to connect, manage, and secure microservices.

In 5 listsDetails

Keepalived

Simple and robust facilities for loadbalancing and high-availability to Linux system and Linux based infrastructures.

Kong

Open source management layer for APIs.

In 9 listsDetails

KrakenD

Open source ultra performance API Gateway.

In 2 lists

Kuma

Platform agnostic open source control plane for service mesh and microservices.

Linkerd

Resilient service mesh for cloud native apps.

In 3 lists

Neutrino

Extensible software load balancer.

OpenResty

Fast web application server built on top of Nginx.

Open Service Mesh

Lightweight and extensible cloud native service mesh.

In 2 lists

Otoroshi

Modern HTTP reverse proxy with lightweight API management.

Pingora

A library for building fast, reliable and evolvable network services.

In 4 listsDetails

Skipper

HTTP router useful for decoupling routing from service logic.

In 3 lists

Spring Cloud Gateway

API Gateway on top of Spring MVC. Aims to provide a simple, yet effective way to route to APIs.

Tengine

A distribution of Nginx with some advanced features.

Træfɪk

A modern HTTP reverse proxy and load balancer made to deploy microservices with ease.

Traffic Server

High-performance building block for cloud services.

Tyk

Open source, fast and scalable API gateway, portal and API management platform.

In 4 listsDetails

Vulcand

Programmatic load balancer backed by Etcd.

In 2 lists

Zuul

An edge service that provides dynamic routing, monitoring, resiliency, security, and more.

In 4 listsDetails

Capabilities >Configuration & Discovery

Central Dogma

Open-source highly-available version-controlled service configuration repository based on Git, ZooKeeper and HTTP/2.

Consul

Service discovery and configuration made easy. Distributed, highly available, and datacenter-aware.

In 6 listsDetails

Etcd

Highly-available key-value store for shared configuration and service discovery.

In 2 lists

Eureka

REST based service that is primarily used in the AWS cloud for locating services for the purpose of load balancing and failover of middle-tier servers.

In 5 listsDetails

Microconfig

Modern and simple way of microservice configuration management.

Nacos

Easy-to-use dynamic service discovery, configuration and service management platform.

In 3 lists

SkyDNS

Distributed service for announcement and discovery of services built on top of etcd. It utilizes DNS queries to discover available services.

Spring Cloud Config

Provides server and client-side support for externalized configuration in a distributed system.

ZooKeeper

Open source server which enables highly reliable distributed coordination.

In 4 listsDetails

Capabilities >Workflow Orchestration

AWS Step Functions (c)

Coordinate the components of distributed applications and microservices using visual workflows.

In 4 listsDetails

Cadence

Fault-oblivious stateful code platform.

Conductor

A microservices orchestration engine.

In 2 lists

Inngest

Durable functions for reliable background logic, from background jobs to complex workflows.

In 4 listsDetails

Kestra

Open source microservices event-driven, language-agnostic orchestration and scheduling platform.

In 8 listsDetails

Temporal

Open source microservices orchestration platform for running mission critical code at any scale.

In 6 listsDetails

Zeebe

Define, orchestrate, and monitor business processes across microservices.

Capabilities >Elasticity

Hazelcast

Open source in-memory data-grid. Allows you to distribute data and computation across servers, clusters and geographies, and to manage very large data sets or high data ingest rates. Mature technology.

In 2 lists

Helix

Generic cluster management framework used for the automatic management of partitioned, replicated and distributed resources hosted on a cluster of nodes.

In 3 lists

Ignite

High-performance, integrated and distributed in-memory platform for computing and transacting on large-scale data sets in real-time, orders of magnitude faster than possible with traditional disk-based or flash technologies.

In 3 lists

Libp2p

A framework and suite of protocols for building peer-to-peer network applications.

In 2 lists

Mesos

Abstracts CPU, memory, storage, and other compute resources away from machines (physical or virtual), enabling fault-tolerant and elastic distributed systems to easily be built and run effectively.

In 2 lists

Nomad

Distributed, highly available, datacenter-aware scheduler.

In 4 listsDetails

Redisson

Distributed and scalable Java data structures on top of Redis server.

In 2 lists

Serf

Decentralized solution for cluster membership, failure detection and orchestration.

In 3 lists

Valkey

A new project to resume development on the formerly open-source Redis project.

In 3 lists

Zenoh

Pub/sub/query protocol unifying data in motion, data at rest and computations. Efficiently blends traditional pub/sub with geo distributed storage, queries and computations.

Capabilities >Job Schedulers / Workload Automation

Celery

Asynchronous task queue/job queue based on distributed message passing. Focused on real-time operation and supports scheduling.

In 6 listsDetails

Dkron

Distributed, fault tolerant job scheduling system.

Faktory

Language-agnostic persistent background job server.

In 3 lists

Rundeck (c)

Job scheduler and runbook automation. Enable self-service access to existing scripts and tools.

In 2 lists

Schedulix

Open source enterprise job scheduling system lays down ground-breaking standards for the professional automation of IT processes in advanced system environments.

Capabilities >Local Development

mirrord

Run local code as if it were a pod in a remote Kubernetes cluster.

In 2 lists

Capabilities >Logging

Fluentd

Open source data collector for unified logging layer.

In 2 lists

Graylog

Fully integrated open source log management platform.

In 4 listsDetails

Kibana

Flexible analytics and visualization platform.

In 7 listsDetails

LogDNA (c)

Centralized log management software. Instantly collect, centralize, and analyze logs in real-time from any platform, at any volume.

In 2 lists

Logstash

Tool for managing events and logs.

Loki

Like Prometheus, but for logs.

In 5 listsDetails

Capabilities >Messaging

ØMQ

Brokerless intelligent transport layer.

ActiveMQ

Powerful open source messaging and integration patterns server.

In 3 lists

Aeron

Efficient reliable UDP unicast, UDP multicast, and IPC message transport.

In 3 lists

Beanstalk

Simple, fast work queue.

In 3 lists

Bull

Fast and reliable Redis-based queue for Node.

In 4 listsDetails

Crossbar

Open source networking platform for distributed and microservice applications. It implements the open Web Application Messaging Protocol (WAMP).

In 2 lists

Kafka

Publish-subscribe messaging rethought as a distributed commit log.

In 6 listsDetails

Malamute

ZeroMQ enterprise messaging broker.

Mosquitto

Open source message broker that implements the MQTT protocol.

NATS

Open source, high-performance, lightweight cloud messaging system.

In 3 lists

NSQ

A realtime distributed messaging platform.

Pulsar

Distributed pub-sub messaging system.

In 2 lists

RabbitMQ

Open source Erlang-based message broker that just works.

In 3 lists

Redpanda

Streaming data platform for developers: Kafka API compatible, 10x faster, no ZooKeeper and no JVM.

In 6 listsDetails

RocketMQ

A low latency, reliable, scalable, easy to use message oriented middleware born from alibaba massive messaging business.

Capabilities >Monitoring & Debugging

Beats

Lightweight shippers for Elasticsearch & Logstash.

In 2 lists

Elastalert

Easy & flexible alerting for Elasticsearch.

In 4 listsDetails

Ganglia

A scalable distributed monitoring system for high-performance computing systems such as clusters and grids.

Grafana

An open source, feature rich metrics dashboard and graph editor for Graphite, InfluxDB & OpenTSDB.

In 3 lists

Graphite

Scalable realtime graphing.

IOpipe (c)

Application performance monitoring for Amazon Lambda.

Jaeger

An open source, end-to-end distributed tracing

In 3 lists

OpenTelemetry

High-quality, ubiquitous, and portable telemetry to enable effective observability.

In 5 listsDetails

Prometheus

An open source service monitoring system and time series database.

Riemann

Monitors distributed systems.

In 3 lists

Sensu

Monitoring for today's infrastructure.

SkyWalking

Application performance monitor tool for distributed systems, especially designed for microservices, cloud native and container-based (Docker, K8s, Mesos) architectures.

Zabbix

Open source enterprise-class monitoring solution.

Zipkin

Distributed tracing system.

Capabilities >Reactivity

Arroyo

Distributed stream processing engine to transform, filter, aggregate, and join data streams by writing SQL.

In 3 lists

Reactor.io

A second-generation Reactive library for building non-blocking applications on the JVM based on the Reactive Streams Specification.

Reactive Kafka

Reactive Streams API for Apache Kafka.

ReactiveX

API for asynchronous programming with observable streams. Available for idiomatic Java, Scala, C#, C++, Clojure, JavaScript, Python, Groovy, JRuby, and others.

In 2 lists

RSocket

Application protocol providing Reactive Streams semantics.

Capabilities >Resilience

Awesome Chaos Engineering

star: - A curated list of awesome chaos engineering resources.

In 2 listsDetails

Raft Consensus

Consensus algorithm that is designed to be easy to understand. It's equivalent to Paxos in fault-tolerance and performance.

In 2 lists

Resilience4j

Fault tolerance library designed for Java8 and functional programming.

In 3 lists

Svix

Webhooks service that sends webhooks to your users with full retry schedules, exponential backoff, signature verification, and event types.

In 2 lists

Capabilities >Security

Cerbos Hub

Authorization management system for authoring, testing, and deploying access policies. Built scalable, fine-grained authorization in a microservice architecture.

In 2 lists

Dex

Opinionated auth/directory service with pluggable connectors. OpenID Connect provider and third-party OAuth 2.0 delegation.

JWT

JSON Web Tokens are an open, industry standard RFC 7519 method for representing claims securely between two parties.

In 2 lists

Keycloak

Full-featured and extensible auth service. OpenID Connect provider and third-party OAuth 2.0 delegation.

In 7 listsDetails

OAuth

Provides specific authorization flows for web applications, desktop applications, mobile phones, and living room devices. Many implementations.

OpenID Connect

Libraries, products, and tools implementing current OpenID specifications and related specs.

Open Ziti

Zero trust security and overlay networking as pure open source software.

In 2 lists

ORY

Open source identity infrastructure and services.

In 2 lists

OWASP Agent Memory Guard

Runtime defense layer for AI agent memory poisoning (OWASP ASI06). Detects tampered memory entries, prompt injection in memory paths, and secret leakage. YAML policies, microsecond latency, zero external dependencies.

In 3 lists

SCIM

System for Cross-domain Identity Management.

Vault

Secures, stores, and tightly controls access to tokens, passwords, certificates, API keys, and other secrets in modern computing.

In 6 listsDetails

Capabilities >Serialization

Avro

Apache data serialization system providing rich data structures in a compact, fast, binary data format.

In 4 listsDetails

Bond

Cross-platform framework for working with schematized data, broadly used at Microsoft in high scale services.

In 4 listsDetails

BooPickle

Binary serialization library for efficient network communication. For Scala and Scala.js

Cap’n Proto

Insanely fast data interchange format and capability-based RPC system.

In 4 listsDetails

CBOR

Implementations of the CBOR standard (RFC 7049) in many languages.

Cereal

C++11 library for serialization.

Cheshire

Clojure JSON and JSON SMILE encoding/decoding.

In 2 lists

Etch

Cross-platform, language and transport-independent framework for building and consuming network services.

Fastjson

Fast JSON Processor.

In 4 listsDetails

Ffjson

Faster JSON serialization for Go.

In 3 lists

FST

Fast java serialization drop in-replacement.

In 2 lists

Jackson

A multi-purpose Java library for processing JSON data format.

In 4 listsDetails

Jackson Afterburner

Jackson module that uses bytecode generation to further speed up data binding (+30-40% throughput for serialization, deserialization).

Kryo

Java serialization and cloning: fast, efficient, automatic.

In 4 listsDetails

Lite³

JSON-compatible zero-copy serialization format.

MessagePack

Efficient binary serialization format.

In 2 lists

Protostuff

A serialization library with built-in support for forward-backward compatibility (schema evolution) and validation.

SBinary

Library for describing binary formats for Scala types.

Thrift

The Apache Thrift software framework, for scalable cross-language services development.

In 3 lists

yyjson

The fastest JSON library in C.

In 4 listsDetails

Capabilities >Storage

Apache Cassandra

Column-oriented and providing high availability with no single point of failure.

In 6 listsDetails

Aerospike (c)

High performance NoSQL database delivering speed at scale.

In 2 lists

ArangoDB

A distributed free and open source database with a flexible data model for documents, graphs, and key-values.

In 7 listsDetails

Citus

Distributed PostgreSQL as an extension.

In 4 listsDetails

CockroachDB (c)

A cloud-native SQL database modelled after Google Spanner.

Couchbase

A distributed database engineered for performance, scalability, and simplified administration.

Crate (c)

Scalable SQL database with the NoSQL goodies.

In 4 listsDetails

Druid

Fast column-oriented distributed data store.

In 4 listsDetails

Elasticsearch

Open source distributed, scalable, and highly available search server.

Geode

Open source, distributed, in-memory database for scale-out applications.

Infinispan

Highly concurrent key/value datastore used for caching.

In 2 lists

InfluxDB

Scalable datastore for metrics, events, and real-time analytics.

In 8 listsDetails

RethinkDB

Open source, scalable database that makes building realtime apps easier.

TiKV

Distributed transactional key-value database.

TimescaleDB

A time-series database for high-performance real-time analytics packaged as a Postgres extension.

In 6 listsDetails

Trino

Fast distributed SQL query engine for big data analytics that helps you explore your data universe.

In 4 listsDetails

Capabilities >Testing

Goreplay

A tool for capturing and replaying live HTTP traffic into a test environment.

In 3 lists

Keploy

Open-source tool for API testing and mocking by capturing real traffic and converting it into test cases and stubs, enabling reliable microservice testing.

In 8 listsDetails

Mitmproxy

An interactive console program that allows traffic flows to be intercepted, inspected, modified and replayed.

In 10 listsDetails

MockServer

Mocking, debugging proxy and chaos engineering for multiple protocols (HTTP, gRPC, GraphQL, LLM, MCP, Kafka, TCP and more); mock dependencies, record/replay traffic, verify requests, and inject faults for integration and resilience testing.

In 2 lists

Mountebank

Cross-platform, multi-protocol test doubles over the wire.

Pact

Contract testing framework for HTTP APIs and non-HTTP asynchronous messaging systems.

In 3 lists

RestQA

A tool to manage microservices mocking, unit and performance testing locally with best in class developer experience.

In 3 lists

Specmatic

Converts API specifications (OpenAPI, AsyncAPI, GraphQL, gRPC etc) into executable contracts for automated testing, service virtualisation, and backward compatibility validation without writing code.

VCR

Record your test suite's HTTP interactions and replay them during future test runs for fast, deterministic, accurate tests. See the list of ports for implementations in other languages.

In 4 listsDetails

Wilma

Combined HTTP/HTTPS service stub and transparent proxy solution.

WireMock

Flexible library for stubbing and mocking web services. Unlike general purpose mocking tools it works by creating an actual HTTP server that your code under test can connect to as it would a real web service.

In 2 lists

Hoverfly

Lightweight service virtualization/API simulation tool for developers and testers.

In 5 listsDetails

Web API Modeling & Documentation >Async

AsyncAPI

AsyncAPI specification, the industry standard for defining asynchronous APIs.

In 2 lists

Web API Modeling & Documentation >GraphQL

GraphQL

Query language designed to build client applications by providing an intuitive and flexible syntax and system for describing their data requirements and interactions.

Web API Modeling & Documentation >JSON

JSON:API

A specification for how a client should request that resources be fetched or modified, and how a server should respond to those requests.

In 4 listsDetails

Web API Modeling & Documentation >REST

API Blueprint

Tools for your whole API lifecycle. Use it to discuss your API with others. Generate documentation automatically. Or a test suite. Or even some code.

In 2 lists

OpenAPI

The OpenAPI Specification (OAS) provides a consistent means to carry information through each stage of the API lifecycle.

In 2 lists

RAML

RESTful API Modeling Language, a simple and succinct way of describing practically-RESTful APIs.

In 2 lists

ReDoc

OpenAPI/Swagger-generated API Documentation.

In 3 lists

Scalar

Open-source API platform: beautiful API references and 1st-class OpenAPI/Swagger support.

In 2 lists

Slate

Beautiful static documentation for your API.

In 2 lists

Spring REST Docs

Document RESTful services by combining hand-written documentation with auto-generated snippets produced with Spring MVC Test.

Swagger

A simple yet powerful representation of your RESTful API.

In 5 listsDetails

Standards / Recommendations >World Wide Web

W3C.REC-Webarch

Architecture of the World Wide Web, Volume One.

RFC3986

Uniform Resource Identifier (URI): Generic Syntax.

RFC6570

URI Template.

RFC7320

URI Design and Ownership.

Standards / Recommendations >Self-sovereignty & Decentralisation

DID

W3C specification of Decentralized identifiers (DIDs): a new type of identifier that enables verifiable, decentralized digital identity.

In 2 lists

DIDComm

Private communication methodology built atop the decentralized design of DIDs.

DIDComm Protocols

Registry of protocols built on DIDComm, for high-trust, self-sovereign interactions over any transport.

IDSA

The International Data Spaces Association (IDSA) is on a mission to create the future of the global, digital economy with International Data Spaces (IDS), a secure, sovereign system of data sharing in which all participants can realize the full value of their data.

Standards / Recommendations >HTTP/1.1

RFC7230

Message Syntax and Routing.

RFC7231

Semantics and Content.

RFC7232

Conditional Requests.

RFC7233

Range Requests.

RFC7234

Caching.

RFC7235

Authentication.

RFC7807

Problem Details for HTTP APIs.

Standards / Recommendations >HTTP/2

RFC7540

Hypertext Transfer Protocol Version 2.

In 2 lists

Standards / Recommendations >QUIC

QUIC-WG

IETF Working Group that is chartered to deliver the next transport protocol for the Internet.

QUIC-Transport

A UDP-based multiplexed and secure transport.

Standards / Recommendations >RPC

JSON-RPC 2.0

A stateless, light-weight remote procedure call (RPC) protocol.

Open RPC

The OpenRPC Specification defines a standard, programming language-agnostic interface description for JSON-RPC 2.0 APIs.

Standards / Recommendations >Messaging

AMQP

Advanced Message Queuing Protocol.

In 2 lists

MQTT

MQ Telemetry Transport.

In 3 lists

STOMP

Simple Text Oriented Messaging Protocol.

In 2 lists

Standards / Recommendations >Security

GNAP

Grant Negotiation and Authorization Protocol defines a mechanism for delegating authorization to a piece of software, and conveying that delegation to the software. This delegation can include access to a set of APIs as well as information passed directly to the software.DRAFT

OIDCONN

OpenID Connect 1.0 is a simple identity layer on top of the OAuth 2.0 protocol. It allows clients to verify the identity of the end-user based on the authentication performed by an Authorization Server, as well as to obtain basic profile information about the end-user in an interoperable and…

PASETO

Paseto is everything you love about JOSE (JWT, JWE, JWS) without any of the many design deficits that plague the JOSE standards. DRAFT

RFC5246

The Transport Layer Security (TLS) Protocol Version 1.2.

RFC6066

TLS Extensions.

RFC6347

Datagram Transport Layer Security Version 1.2.

RFC6749

The OAuth 2.0 authorization framework.

RFC6962

Certificate transparency.

RFC7515

JSON Web Signature (JWS) represents content secured with digital signatures or Message Authentication Codes (MACs) using JSON-based data structures.

RFC7519

JSON Web Token (JWT) is a compact, URL-safe means of representing claims to be transferred between two parties.

RFC7642

SCIM: Definitions, overview, concepts, and requirements.

RFC7643

SCIM: Core Schema, provides a platform-neutral schema and extension model for representing users and groups.

RFC7644

SCIM: Protocol, an application-level, REST protocol for provisioning and managing identity data on the web.

Standards / Recommendations >Service Discovery

DNS-SD

Mechanism for clients to discover a list of named instances of a service, using standard DNS queries.

RFC2782

A DNS RR for specifying the location of services (DNS SRV).

Standards / Recommendations >Data Formats

RFC4627

JavaScript Object Notation (JSON).

RFC7049

Concise Binary Object Representation (CBOR).

BSON

Binary JSON (BSON).

JSON-LD

JSON for Linking Data.

In 2 lists

SBE

Simple Binary Encoding (SBE).

MSGPACK

MessagePack Specification.

In 2 lists

Standards / Recommendations >Vocabularies

JSON Schema

Vocabulary that allows you to annotate and validate JSON documents.

In 2 lists

Schema.org

Collaborative, community activity with a mission to create, maintain, and promote schemas for structured data on the Internet, on web pages, in email messages, and beyond.

In 2 lists

Standards / Recommendations >Unicode

UNIV8

The Unicode Consortium. The Unicode Standard, Version 8.0.0, (Mountain View, CA: The Unicode Consortium, 2015. ISBN 978-1-936213-10-8).

In 2 lists

RFC3629

UTF-8, a transformation format of ISO 10646.

Organization Design / Team Dynamics

How Do Committees Invent?

small_orange_diamond:PDF - Melvin E. Conway, Datamation magazine 1968. The original article defining Conway's Law.

Service per Team

Each team is responsible for one or more business functions (e.g. business capabilities). A team owns a code base consisting of one or more modules. Its code base is sized so as to not exceed the cognitive capacity of team. The team deploys its code as one or more services. A team should have…

Start with Team Cognitive Load - Team Topologies

small_red_triangle:YT - DOES19 London. The "monoliths vs microservices" debate often focuses on technological aspects, ignoring strategy and team dynamics. Instead of technology, smart-thinking organizations are beginning with team cognitive load as the guiding principle for modern software. In…

Enterprise & Verticals

Commercetools

Headless commerce platform.

Equinox

Infosys Equinox is a human-centric commerce and marketing platform that supports rich, hyper-personalized experiences across any channel and touchpoint.

Flamingo

Framework to build flexible and modern e-commerce applications.

Medusa

Headless open source commerce platform.

In 3 lists

Theory >Articles & Papers

Autonomy, Hyperconnectivity, and Residual Causality

Philosophical introduction to the design of adaptive hyperliminal systems through complexity science theories.

Awesome Scalability

star: - An updated and organized reading list for illustrating the patterns of scalable, reliable, and performant large-scale systems. Concepts are explained in the articles of prominent engineers and credible references. Case studies are taken from battle-tested systems that serve millions to…

In 5 listsDetails

AKF Scale Cube

Model depicting the dimensions to scale a service.

CALM

small_orange_diamond:PDF - Consistency as logical monotonicity.

Canary Release

Technique to reduce the risk of introducing a new software version in production by slowly rolling out the change to a small subset of users before rolling it out to the entire infrastructure and making it available to everybody.

CAP Theorem

States that it is impossible for a distributed computer system to simultaneously provide all three of the following guarantees: Consistency, Availability and Partition tolerance.

Formal Foundations of Serverless Computing

small_orange_diamond:PDF - The serverless computing abstraction exposes several low-level operational details that make it hard for programmers to write and reason about their code. This paper sheds light on this problem by presenting λ, an operational semantics of the essence of serverless…

Microservice Architecture

Particular way of designing software applications as suites of independently deployable services.

Microservices - From Design to Deployment

small_orange_diamond:PDF - F5's seven-part series on microservices.

Microservices – Please, don’t

Critical advice about some problems regarding a microservices approach.

In 2 lists

Microservices Trade-Offs

Guide to ponder costs and benefits of the mircoservices architectural style.

Reactive Manifesto

Reactive systems definition.

Reactive Streams

Initiative to provide a standard for asynchronous stream processing with non-blocking back pressure.

In 2 lists

ROCAS

small_orange_diamond:PDF - Resource Oriented Computing for Adaptive Systems.

SECO

small_orange_diamond:PDF - Understanding software ecosystems: a strategic modeling approach.

Testing Strategies in a Microservice Architecture

Approaches for managing the additional testing complexity of multiple independently deployable components.

Your Server as a Function

small_orange_diamond:PDF - Describes three abstractions which combine to present a powerful programming model for building safe, modular, and efficient server software: Composable futures, services and filters.

Theory >Sites & Organizations

Cloud Native Computing Foundation

The Cloud Native Computing Foundation builds sustainable ecosystems and fosters a community around a constellation of high-quality projects that orchestrate containers as part of a microservices architecture.

In 2 lists

CNCF Cloud Native Interactive Landscape

Interactive landscape of cloud native technologies.

In 2 lists

Microservices Resource Guide

Martin Fowler's choice of articles, videos, books, and podcasts that can teach you more about the microservices architectural style.

Microservice Patterns

Microservice architecture patterns and best practices.

Microservice Antipatterns and Pitfalls

Microservice mostly known antipatterns and pitfalls.

In 2 lists
See category
94

Awesome OpenClaw Skills

VoltAgent/awesome-openclaw-skills

The awesome collection of OpenClaw skills. 5,400+ skills filtered and categorized from the official OpenClaw Skills Registry.🦞

Fresh★ 53k830 entriesPushed today
92

Awesome DeepSeek Harness (DSH) Plugin

awesome-dsh-plugin/awesome-dsh-plugin

A curated list of plugins for DeepSeek Harness (dsh) · DeepSeek Harness 插件精选列表

Fresh★ 17k1654 entriesPushed today
91

Awesome Guidelines

Kristories/awesome-guidelines

Programming style, best practices, and coding conventions.

Fresh★ 11k166 entriesPushed 2 days ago
90

Awesome

sindresorhus/awesome

😎 Awesome lists about all kinds of interesting topics [NOTE: Pull requests are temporarily disabled until I have a chance to catch up with the existing ones]

Fresh★ 513k51 entriesPushed 28 days ago
90

Awesome Prompts

ai-boost/awesome-prompts

Curated list of chatgpt prompts from the top-rated GPTs in the GPTs Store. Prompt Engineering, prompt attack & prompt protect. Advanced Prompt Engineering papers.

Fresh★ 9k288 entriesPushed yesterday
90

Awesome README

matiassingers/awesome-readme

A curated list of awesome READMEs

Fresh★ 22k143 entriesPushed yesterday